Ein neues Thema erstellen  Auf das Thema antworten  [ 14 Beiträge ] 
Autor Nachricht
BeitragVerfasst: 04.03.2006, 12:57 

Registriert: 18.08.2003, 22:37
Beiträge: 15
Hallo.

Ja ich habe die Suche schon bemüht, aber keine Lösung gefunden.
Server: Linux
Adminmod läuft in der Version 2.50.60
Metamod: 1.17.2

Plugin sank_sounds läuft in einer älteren Version.
Nun wollte ich mehr als 40 Sounds ermöglich und sah,
das in der neuen Version schon 200 eingetragen ist.
Habe die sma mit dem Adminmod-Tool SMA_zu_AMX
compiliert und convertiert.
Keine Fehlermeldung.
Habe dann die Linuxdatei hochgeladen (altes Plugin vorher umbenannt!),
rebootet und nix geht.
Wenn ich das alte Plugin wieder nehme geht alles, aber nur 40 Sounds.
Dieses Plugin hatte nicht ich, sondern der alte Serveradmin compiliert,
daher habe ich da keine sma-datei mehr von.
Wo kann ich jetzt nach dem Fehler suchen?

Danke im Voraus.
Bucc


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 04.03.2006, 20:46 
AM.de Team
Benutzeravatar

Registriert: 23.11.2001, 00:00
Beiträge: 3841
Wohnort: Vor König Arthus
Soweit ich mich erinnere muss eigentlich nur eine Variable im Original-Sank Sound Plugin von 40 auf 200 gestellt werden und anschließend neu compiliert. Vielleicht hast Du aber auch eine ältere Version gehabt. Ich würde mal die Syntax in der Soundliste überprüfen. Vielleicht hat die sich geändert.

_________________
Der schwarze Ritter triumphiert immer...
WING-Clan


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 05.03.2006, 13:24 

Registriert: 18.08.2003, 22:37
Beiträge: 15
Also die Syntax in der Soundlist war es bisher nicht.
Leider habe ich ja die alte SMA Datei nicht mehr, sonst
hätte ich das so gemacht.
Kann ich die Irgendwo her bekommen?
Ich versuche es weiter.

Danke und Gruß
Bucc


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 08.03.2006, 12:56 

Registriert: 18.08.2003, 22:37
Beiträge: 15
Also ich habe jetzt des öfteren compiliert und
hochgeladen. Ich habe nur das Plugin ersetzt,
da durch die Vorversion ja der Eintrag in der
Plugin.ini steht.
Aber es geht nicht.
Hat noch jemand die alte sma-Datei mit dem
Eintrag 40 ?

Danke
Bucc


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 08.03.2006, 18:24 
AM.de Team
Benutzeravatar

Registriert: 23.11.2001, 00:00
Beiträge: 3841
Wohnort: Vor König Arthus
Hmm, das hier ist die älteste Version, die ich auf meiner Platte finden konnte.


Dateianhänge:
plugin_sank_sounds.zip [202.6 KiB]
644-mal heruntergeladen

_________________
Der schwarze Ritter triumphiert immer...
WING-Clan


Zuletzt geändert von [WING] Black Knight am 09.03.2006, 22:47, insgesamt 1-mal geändert.
Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 09.03.2006, 21:35 

Registriert: 18.08.2003, 22:37
Beiträge: 15
Ich kann leider nicht herunterladen.
Folgende Meldung:
Das ausgewählte Attachment existiert leider nicht mehr

404 File Not Found: The File files/plugin_sank_sounds_315.zip does not exist.

Bucc


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 09.03.2006, 22:48 
AM.de Team
Benutzeravatar

Registriert: 23.11.2001, 00:00
Beiträge: 3841
Wohnort: Vor König Arthus
Tja, da war wohl doch eine Datei beim Umzug hopps gegangen. So, sollte wieder da sein.

_________________
Der schwarze Ritter triumphiert immer...
WING-Clan


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 10.03.2006, 08:04 

Registriert: 18.08.2003, 22:37
Beiträge: 15
Erst mal thx.

Hm, bin jetzt etwas ratlos.
Habe die sma auf 200 einträge geändert, compiliert,
hochgeladen und funzt nicht.
Dann habe ich das Plugin umbenannt und das alte wieder
aktiviert.
In CS eingewählt, auf die Windowsebene gewechselt und per
ftp die Plugins umbenannt, das ich das neue aktiv habe.
Erst geht es, wenn ich aber CS verlasse und mich neu auf den Server einwähle geht es nicht mehr.
Das kann ich nicht nachvollziehen.
Das nicht funktionieren heisst: ich tippe z.B. TACH und es erscheint
nur als Chat und wird nicht mit einem Sound aufgerufen.

Ich bräuchte mal einen Ansatz zur Lösung.

Gruss Bucc


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 10.03.2006, 17:44 
AM.de Team
Benutzeravatar

Registriert: 23.11.2001, 00:00
Beiträge: 3841
Wohnort: Vor König Arthus
Kannst Du mal die zugehörigen Logeinträge ich posten. Also einmal vom funktionierenden und einmal vom nicht funktionierenden.

Das Umbenennen von Plugins auf dem Server hat erst bei einem Mapwechsel Auswirkungen.

_________________
Der schwarze Ritter triumphiert immer...
WING-Clan


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 12.03.2006, 05:07 
AM.de Team
Benutzeravatar

Registriert: 27.11.2001, 01:00
Beiträge: 3564
Wohnort: In der Nähe von Bonn
im neuen Download, was Blacky anbietet, da gehört die snd-list.cfg nach addons\adminmod\config\ und nicht mehr wie früher beim alten in den cstrike Ordner!

Einfach Datei nach addons\adminmod\config\ auschneiden...

Vllt. liegt es daran?

_________________
Fehleranalyse: Poste den Inhalt Deiner liblist.gam, (listen)server.cfg, adminmod.cfg, users.ini, vault.ini, plugin.ini von adminmod und plugins.ini von metamod. Benutze auch die Such-Funktion


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 13.03.2006, 12:51 

Registriert: 18.08.2003, 22:37
Beiträge: 15
Also das mit den Logdateien werde ich noch machen.
Die SND-LIST.cfg liegt beim aktuellen Plugin schon
in addons\adminod\config\.
Melde mich sobald ich die Logeintäge habe.

Gruß


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 14.03.2006, 06:04 

Registriert: 18.08.2003, 22:37
Beiträge: 15
Also die snd-list.fcg darf nicht in addons\adminod\config\ liegen, dann funktioniert es nicht.
Egal ob neues oder altes Plugin, dies ist das neue.
Code:
L 03/14/2006 - 05:41:20: [ADMIN] Fully initializing data.
L 03/14/2006 - 05:41:20: Started map "de_dust2" (CRC "1159425449")
L 03/14/2006 - 05:41:20: [STATSME] Loading statsme rank (file "cstrike/addons/statsme/statsme.log") (game "cstrike") (version "15")
L 03/14/2006 - 05:41:20: [STATSME] Loaded 805 records
L 03/14/2006 - 05:41:20: [STATSME] Loading statsme rank (file "cstrike/addons/statsme/statsme.log") (game "cstrike") (version "14")
L 03/14/2006 - 05:41:20: [STATSME] Loaded 805 records
L 03/14/2006 - 05:41:21: World triggered "Round_Start"
L 03/14/2006 - 05:41:48: "Bucc@neer<698><STEAM_ID_PENDING><>" connected, address "87.123.65.224:63503"
L 03/14/2006 - 05:41:48: [ADMIN] Loading users from file 'addons/adminmod/config/users.ini'
L 03/14/2006 - 05:41:48: [ADMIN] Loaded 11 users
L 03/14/2006 - 05:41:48: [ADMIN] Loading vault records from file 'addons/adminmod/config/vault.ini'
L 03/14/2006 - 05:41:48: [ADMIN] Loaded 2 vault records
L 03/14/2006 - 05:41:48: [ADMIN] Loading words from file 'wordlist.txt'
L 03/14/2006 - 05:41:48: [ADMIN] Loaded 77 words
L 03/14/2006 - 05:41:48: [ADMIN] Loading plugins from file 'addons/adminmod/config/plugin.ini'
L 03/14/2006 - 05:41:48: Counter-Strike Plugin: No saved weapon restrictions found.
L 03/14/2006 - 05:41:48: [ADMIN] [plugin_sank_sounds] Cannot find SND-LIST.CFG file.
L 03/14/2006 - 05:41:48: [plugin_sank_sounds] Cannot find SND-LIST.CFG file.
L 03/14/2006 - 05:41:48: [ADMIN] Loaded 16 plugins
L 03/14/2006 - 05:41:48: [ADMIN] Plugins loaded successfully.
Hier ist das alte Plugin aktiv und die snd-list.cfg liegt in:
addons\adminod\
Code:
L 03/14/2006 - 05:29:33: [ADMIN] Fully initializing data.
L 03/14/2006 - 05:29:33: Started map "de_dust" (CRC "-1641307065")
L 03/14/2006 - 05:29:33: [STATSME] Loading statsme rank (file "cstrike/addons/statsme/statsme.log") (game "cstrike") (version "15")
L 03/14/2006 - 05:29:33: [STATSME] Loaded 805 records
L 03/14/2006 - 05:29:33: [STATSME] Loading statsme rank (file "cstrike/addons/statsme/statsme.log") (game "cstrike") (version "14")
L 03/14/2006 - 05:29:34: [STATSME] Loaded 805 records
L 03/14/2006 - 05:29:34: World triggered "Round_Start"
L 03/14/2006 - 05:33:34: Team "CT" triggered "Target_Saved" (CT "1") (T "0")
L 03/14/2006 - 05:33:34: World triggered "Round_End"
L 03/14/2006 - 05:33:39: World triggered "Round_Start"
L 03/14/2006 - 05:37:39: Team "CT" triggered "Target_Saved" (CT "2") (T "0")
L 03/14/2006 - 05:37:39: World triggered "Round_End"
L 03/14/2006 - 05:37:44: World triggered "Round_Start"
L 03/14/2006 - 05:39:01: "Bucc@neer<697><STEAM_ID_PENDING><>" connected, address "87.123.65.224:63503"
L 03/14/2006 - 05:39:01: [ADMIN] Loading users from file 'addons/adminmod/config/users.ini'
L 03/14/2006 - 05:39:01: [ADMIN] Loaded 11 users
L 03/14/2006 - 05:39:01: [ADMIN] Loading vault records from file 'addons/adminmod/config/vault.ini'
L 03/14/2006 - 05:39:01: [ADMIN] Loaded 2 vault records
L 03/14/2006 - 05:39:01: [ADMIN] Loading words from file 'wordlist.txt'
L 03/14/2006 - 05:39:01: [ADMIN] Loaded 77 words
L 03/14/2006 - 05:39:01: [ADMIN] Loading plugins from file 'addons/adminmod/config/plugin.ini'
L 03/14/2006 - 05:39:01: Counter-Strike Plugin: No saved weapon restrictions found.
L 03/14/2006 - 05:39:01: [ADMIN] Sound quota set to 20
L 03/14/2006 - 05:39:01: [ADMIN] Sound Plugin >> addons/adminmod/SND-LIST.CFG successfully loaded.
L 03/14/2006 - 05:39:01: Sound Plugin >> addons/adminmod/SND-LIST.CFG successfully loaded.
L 03/14/2006 - 05:39:01: [ADMIN] Loaded 16 plugins
L 03/14/2006 - 05:39:01: [ADMIN] Plugins loaded successfully.
L 03/14/2006 - 05:39:02: "Bucc@neer<697><STEAM_0:1:140726><>" STEAM USERID validated
L 03/14/2006 - 05:39:03: Server cvar "public_slots_free" = "15"
L 03/14/2006 - 05:39:32: "Bucc@neer<697><STEAM_0:1:140726><>" entered the game
L 03/14/2006 - 05:39:39: "Bucc@neer<697><STEAM_0:1:140726><>" joined team "CT"
L 03/14/2006 - 05:39:46: [ADMIN] (say) Bucc@neer :    tach
L 03/14/2006 - 05:39:52: [ADMIN] (say) Bucc@neer :    prima
L 03/14/2006 - 05:39:52: [ADMIN] (say) Bucc@neer :    scheisse
Da ging es, mit dem neuen nicht.

Da ich ab Samstag in Urlaub bin,
sage ich erst mal thx und versuche
es in 14 Tagen wieder.

Danke und Gruß
Bucc


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 14.03.2006, 18:57 
AM.de Team
Benutzeravatar

Registriert: 27.11.2001, 01:00
Beiträge: 3564
Wohnort: In der Nähe von Bonn
die *.sma Datei mit Notepad öffnen
nach SND-List.cfg suchen
den Pfad merken und die SND-LIST.cfg auf dem Server da hin kopieren...

Bei Blackys zip-Datei gehört sie nach:
new FILENAME[MAX_DATA_LENGTH] = "addons\adminmod\config\snd-list.cfg";

Jetzt frag ich mich natürlich wieder:

a. Muss es zur Pfadangabe nicht / sein anstatt \
b. die in der sma angebebene Datei heisst snd-list.cfg und nicht SND-LIST.cfg
c. Windows ist glaube ich alles egal, wie man es schreibt, aber Linux ist eventuell mal wieder konsequent... (wollte erst pingelig schreiben, aber dann hauen mich wieder die Linuxer)... und es muss wirklich auf das richtige / bzw \ bzw. Dateinamen geachtet werden :)

_________________
Fehleranalyse: Poste den Inhalt Deiner liblist.gam, (listen)server.cfg, adminmod.cfg, users.ini, vault.ini, plugin.ini von adminmod und plugins.ini von metamod. Benutze auch die Such-Funktion


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 13.04.2006, 10:28 

Registriert: 18.08.2003, 22:37
Beiträge: 15
Moin,

nach dem Urlaub und viel Arbeit, bin ich endlich
wieder dazu gekommen mich mit dem Plugin
zu beschäftigen.

Habe von Null angefangen:
- heruntergeladen
- installiert
-> funzt ! :)

Die Config habe ich jetzt in: addons\adminmod\config\snd-list.cfg
Vorher hatte ich sie doch nur in: addons\adminmod\snd-list.cfg

Ich habe sie zur Sicherheit auch klein geschrieben.

Vielen Dank für die Mühe und die guten Tips.

Gruß Bucc@neer :wink:

P.S.: Ich denke der Thread kann geschlossen werden.


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 14 Beiträge ] 


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.
Du darfst keine Dateianhänge in diesem Forum erstellen.

Suche nach:
cron
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de
Original Design von "[ Half-Life Admin Mod © Alfred Reynolds 2000-2003 ] - [ site design by Jägermeister ]"